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Getting Started Accessing Statistical Software Inside the U Iowa Virtual Desktop 

(i.e., how to freely access SAS, STATA, or R for use on-campus or off-campus) 

 

Step 1a. You will need to have already configured two-factor authentication using Duo Security for 

your university accounts. Instructions are here: https://its.uiowa.edu/duo  

 

Step 1b. If you are off-campus, you will need to have the VPN running in the background. You can 

download the program and instructions here: https://its.uiowa.edu/vpn  

When the window pops us for you to log into the VPN program (Cisco AnyConnect), you will 

enter your HawkID name and usual password. The box called second password refers to a 

two-factor authentication method. If you type push it will ping your two-factor program for 

approval (i.e., as installed on your smart phone). Alternatively, if you type sms it will tell you 

that you could not log in, but ignore this. In the box that appears again, enter your same 

HawkID and usual password, and then for the second password enter one of the six-digit codes 

that should have been sent in a text message. 

 

Step 1c. If you are on-campus, you will need to be connected to the eduroam UIowa network. To do 

so, your username is your HawkID@uiowa.edu (i.e., it is a combination of your HawkID name with 

an email-address-like ending, but it’s not your actual email address). 

 

 

Step 2. If you haven’t already do so, map your H: drive to your computer, which is a campus 

network drive that will be the most easily linked to the Virtual Desktop software. (You don’t have to 

use it, but previous students have had the most success putting files here). Instructions to do so for both 

Windows and Mac are here: https://its.uiowa.edu/support/article/104047 

 

 

  

https://its.uiowa.edu/duo
https://its.uiowa.edu/vpn
https://its.uiowa.edu/support/article/104047
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Step 3a. Download the Example 1 files from here: 

https://www.lesahoffman.com/PSQF6243/PSQF6243_Example1.zip  

The Example1 folder includes an Excel data file (.xlsx extension), program syntax files (as .sas 

for SAS, .do for STATA, .and .R for R), and output files so you can see what each program 

does (as .rtf for SAS, .log for STATA, and .txt for R). Plots from both STATA and R are also 

saved in separate .png files; the plots are embedded in the SAS .rtf output already. 

It may be easiest if you put the Example1 folder inside your university H: drive (but any folder on your 

local computer can be used, so long as you can navigate to it). For this demonstration, I saved the 

PSQF6243_Example1.zip folder directly to my H drive (as shown below).  

 

Step 3b. The files must be extracted before use, a command you can access from the toolbar  

(as shown by the arrow below) or by right-clicking on the folder and selecting “extract all”: 

 

 

  

https://www.lesahoffman.com/PSQF6243/PSQF6243_Example1.zip
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Step 4a. After completing steps 1–3, you can access the U Iowa Virtual Desktop login from this page: 

https://its.uiowa.edu/virtualdesktop 

If you have not already downloaded and installed the Citrix Workspace program that runs the Virtual 

Desktop, it will prompt you do so.  

Once the program is installed, you can open it and a log-in box will appear. Enter your HawkID name 

and usual password for the domain IOWA as shown below:  

 

Once logged in, the front page will look something like this (if you haven’t used it before): 

 

 

https://its.uiowa.edu/virtualdesktop
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Step 4b. Go to APPS → Categories → Miscellaneous. You will find Windows Explorer 

(highlighted by the arrow below) which will be critically useful in telling Virtual Desktop how to 

access the files on your local computer. Click the down arrow on the program, and then click on the 

star next to “add to favorites” and it will be saved to your home screen. 

 

Step 4c. Go to APPS → Categories → Statistical Analysis. There you will find the programs we will 

need: SAS 9_4, Stata 18 BE, or RStudio (as highlighted by the pink stars below). For each, click the 

down arrow on the program, and then click on the star next to “add to favorites” and it will be saved to 

your home screen (as indicated by the yellow stars within each icon below). 
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Step 5a. Open Windows Explorer from inside the Virtual Desktop (i.e., NOT the same program on 

your local computer) by clicking on its icon, which will look something like this. 

 

Step 5b. Navigate to the folder that has your Example 1 files, either using the tree structure on the 

left or the drill-down menu at the top. For example, below is my folder in my H: drive. Under View, 

check the box for File name extensions (as shown by the pink arrow) to make it easier to see your file 

types. 

 

Note that by default when you extract .zipped files, it puts a subfolder of the same name inside the 

folder! Once you are inside the folder, put your cursor into the top address bar, and it will collapse 

into a link that can be copied to your clipboard. Here is mine (note the nested folders): 

H:\PSQF6243_Example1\PSQF6243_Example1  
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Step 6a for SAS. From the original Virtual Desktop page, open SAS. Put your cursor in the bottom 

right box labeled “Editor – Untitled 1”. On the File menu, select Open Program: 

 

Navigate to your Example1_SAS_Syntax.sas file and open it. It should look like this: 

 

To make line numbers visible on your syntax (i.e., as shown on the left side of the file above), go to 

Tools → Options → Enhanced Editor → General tab, and check the box Show Line Numbers (see 

pink arrow below). Under the Appearance tab, you can change the font as well. 



PSQF 6243 Intro to Virtual Desktop page 7  

 

 

 

Step 6b for SAS. In the Example1_SAS_Syntax.sas file, scroll to line 22 where it says  

%LET filesave= C:\Dropbox\22SP_PSQF6243\PSQF6243_Example1;  

 

This is where *MY* files were. To change it, paste in the path (after the =) that you found from 

Windows Explorer in Step 5b—this will tell SAS where your folder is that contains the data file to be 

used. End the path with a semi-colon. The path for my H drive folder would look like this: 

%LET filesave= H:\PSQF6243_Example1\PSQF6243_Example1; 

Here are some more examples of what that path would look like using different operating systems and 

folder locations, assuming your folder is called “PSQF6243_Example1”: 

* Windows example using UIowa Virtual Desktop outside H drive; 

  %LET filesave= \\Client\C:\Dropbox\PSQF6243_Example1; 

 

* Mac example using UIowa Virtual Desktop and H drive (multiple H drives); 

  %LET filesave= \\home.iowa.uiowa.edu\hawkID\PSQF6243_Example1; 

 

* Mac example using UIowa Virtual Desktop outside H drive; 

  %LET filesave= \\Client\C:/Users/username/Desktop/PSQF6243_Example1; 
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Step 6a for STATA. From the original Virtual Desktop page, open Stata 18 BE.  

On the File menu, select Open: 

 

Change the bottom-right menu to Do Files (*.do, *.ado) and navigate to your 

Example1_STATA_Syntax.sas file and open it. The menu should look like this: 

 

 



PSQF 6243 Intro to Virtual Desktop page 9  

 

Step 6b for STATA. A new syntax window should have opened separately from the previous STATA 

program window. Scroll to line 28 where it says  

cd "C:\Dropbox\24_PSQF6243\PSQF6243_Example1"  

 It should look like this:  

  

This is where *MY* files were. To change it, paste in the path (within the quotes) that you found 

from Windows Explorer in Step 5b—this will tell STATA where your folder is that contains the data 

file to be used. The path for my H drive folder would look like this: 

cd "H:\PSQF6243_Example1\PSQF6243_Example1"  

Here are some more examples of what that path would look like using different operating systems and 

folder locations, assuming your folder is called “PSQF6243_Example1”: 

// Windows example using UIowa Virtual Desktop outside H drive 

   cd "\\Client\C:\Dropbox\PSQF6242_Example1" 

// Windows example using Desktop STATA outside H drive 

   cd "C:\Dropbox\PSQF6243_Example1" 

// Mac example using UIowa Virtual Desktop and H drive (multiple H drives) 

   cd "\\home.iowa.uiowa.edu\hawkID\PSQF6243_Example1" 

// Mac example using UIowa Virtual Desktop outside H drive 

   cd "\\Client\C:/Users/username/Desktop/PSQF6243_Example1" 

// Mac example using Desktop STATA outside H drive 

   cd "C:\Users\username\Desktop\PSQF6243_Example1" 
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Step 6a for R. From the original Virtual Desktop page, open Rstudio (not R by itself). 

On the File menu, select Open File: 

 

Step 6b for R. Navigate to your Example1_R_Syntax.R file and open it. Scroll down to line 31.  

The screen should look like this, with a new syntax window in the upper-left corner: 

 

On line 31 it says:  setwd("C:/Dropbox/24_PSQF6243/PSQF6243_Example1/") 
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This is where *MY* files were. To change it, paste in the path (within the quotes) that you found 

from Windows Explorer in Step 5b—this will tell R where your folder is that contains the data file to 

be used. One catch is that you must turn the slashes around in Windows. So the path for my H drive 

folder (with reversed slashes relative to Windows) would look like this (last slash is optional): 

setwd("H:/PSQF6243_Example1/PSQF6243_Example1") 

You can also navigate to where your folder is in the Files menu (in lower-right window). Then select 

More → Set as Working Directory. In the output window, it will write the command you just 

executed, which you can copy into your setwd ( ) function between the quotes. 

______________________________________________________________________________ 

Step 7. You should now be able to run the syntax file without errors in each program. I would 

recommend running the syntax in chunks so you can see what happens at each step.  

To run SAS syntax: Highlight the text to be executed and hit either F3 (windows) or F8 (mac) to 

execute (or move the mouse carefully to the running-man icon on the toolbar).  

To run STATA syntax: Highlight the text to be executed and hit control+D to execute  

(or move the mouse to the “run” icon in the toolbar). 

To run R syntax: Highlight the text to be executed and hit control+enter to execute  

(or move the mouse to the “run” icon in the toolbar). 

_____________________________________________________________________________ 

 

STATA: In case of emergency… if working with the Virtual Desktop is too annoying or you need to 

use Stata without an internet connection, you can purchase a six-month student license for $48 here: 

https://www.stata.com/order/new/edu/gradplans/student-pricing/  

SAS: In case of emergency… if working with the Virtual Desktop is too annoying, another way to 

access SAS for free is through SAS On-Demand, which operates through a web browser: 

https://www.sas.com/en_us/software/on-demand-for-academics.html   

R: In case of emergency… if working with the Virtual Desktop is too annoying, R+Rstudio can be 

installed on your local machine. R download (install first): https://www.r-project.org/  

Rstudio download (install second): https://www.rstudio.com/products/rstudio/  

To edit your syntax files outside the program, I strongly recommend using a plain-text editor, such 

as WordPad for Windows or TextEdit for Mac. I like the program TextPad, which allows you to install 

syntax definition files (i.e., so that the same coloring is used as in the software).  

Download TextPad generic syntax editor: https://www.textpad.com/download 

Download “SAS4” or “Stata” or “R” syntax definitions (save to “system” folder of TextPad, 

then install as “New Document Class”): https://www.textpad.com/addons/syntax-n2t 

https://www.stata.com/order/new/edu/gradplans/student-pricing/
https://www.sas.com/en_us/software/on-demand-for-academics.html
https://www.r-project.org/
https://www.rstudio.com/products/rstudio/
https://www.textpad.com/download
https://www.textpad.com/addons/syntax-n2t

